ubuntuにおけるios14のfuturerestoreについて

備忘録

環境

  • vmware workstation 16
  • ubuntu 20.04lts
  • bash

iphone6s 14.4 -> 14.3rc で動作確認しました

vmware側の設定

仮想マシン設定 > USBコントローラ > USBの互換性 を3.1に設定してください。そうしないとFuturerestoreが通常状態のiPhoneを認識できないようです
frusb

ビルドする

ubuntu20.04ltsならこれを実行すれば勝手にビルドしてくれます。すごいね

途中で「Enter Y if futurerestore will be used on A13/A14 devices」とか言われるので、実行したい端末と相談してYとかNとか押してください。PCの前でシャゲダンをするとビルド時間が縮まるようです

実行

tools4hackみて頑張ってください。2年前の記事ですが、使用方法は変わっていません

a12/a13/a14は実行前にapnonceの確認を忘れずに!切り替わっている可能性もあります

fr

チンパンジーは成功させましたよ、ニンゲン共は?